Droite rationnelle

Merci !

Annales corrigées
Classe(s) : Tle S | Thème(s) : Arithmétique
Type : Exercice | Année : 2016 | Académie : France métropolitaine

France métropolitaine • Juin 2016

Exercice 3 • 5 points

Droite rationnelle

Pour tout couple d’entiers relatifs non nuls (ab), on note pgcd(ab) le plus grand diviseur commun de a et b.

Le plan est muni d’un repère (Oi,j).

▶ 1. Exemple. Soit Δ1 la droite d’équation y=54x23.

a) Montrer que si (x, y) est un couple d’entiers relatifs alors l’entier 15– 12y est divisible par 3.

b) Existe-t-il au moins un point de la droite Δ1 dont les coordonnées sont deux entiers relatifs ? Justifier.

Généralisation. On considère désormais une droite Δ d’équation (E) : y=mnxpq m, n, p et q sont des entiers relatifs non nuls tels que pgcd(m, n= pgcd(p, q= 1.

Ainsi, les coefficients de l’équation (E) sont des fractions irréductibles et on dit que Δ est une droite rationnelle.

Le but de l’exercice est de déterminer une condition nécessaire et suffisante sur m, n, p et q pour qu’une droite rationnelle Δ comporte au moins un point dont les coordonnées sont deux entiers relatifs.

▶ 2. On suppose ici que la droite Δ comporte un point de coordonnées (x0, y0) où x0 et y0 sont des entiers relatifs.

a) En remarquant que le nombre ny0 – mx0 est un entier relatif, démontrer que q divise le produit np.

b) En déduire que q divise n.

▶ 3. Réciproquement, on suppose que q divise n, et on souhaite trouver un couple (x0, y0) d’entiers relatifs tels que y0=mnx0pq.

a) On pose = qr, où r est un entier relatif non nul. Démontrer qu’on peut trouver deux entiers relatifs u et v tels que qru mv = 1.

b) En déduire qu’il existe un couple (x0, y0) d’entiers relatifs tels que y0=mnx0pq.

▶ 4. Soit Δ la droite d’équation y=38x74. Cette droite possède-t-elle un point dont les coordonnées sont des entiers relatifs ? Justifier.

▶ 5. On donne l’algorithme suivant :

Variables

M, N, P, Q : entiers relatifs non nuls,

tels que pgcd(M, N= pgcd(P, Q= 1

X : entier naturel

Entrées

Saisir les valeurs de M, N, P et Q

Traitement et sorties

Si Q divise N alors

X prend la valeur 0

Tant que (MNXPQ n’est pas entier) et (MNXPQ n’est pas entier) faire

X prend la valeur X + 1

Fin tant que

Si MNXPQ est entier alors

Afficher X  MNXPQ

Sinon

Afficher – X  MNXPQ

Fin Si

Sinon

Afficher « Pas de solution »

Fin Si

a) Justifier que cet algorithme se termine pour toute entrée de M, N, P et Q, entiers relatifs non nuls tels que pgcd(M, N= pgcd(P, Q= 1.

b) Que permet-il d’obtenir ?

Les clés du sujet

Durée conseillée : 70 minutes.

Les thèmes clés

Arithmétique • Algorithmique.

Nos coups de pouce

 3. a) Pensez au théorème de Bézout.

 5. a) Pensez à exploiter la question 3. b) pour justifier l’arrêt de l’algorithme dans le premier cas envisagé.

Pour lire la suite :