Algorithmique

Merci !

Fiches
Classe(s) : 1re S
Corpus Corpus 1
Algorithmique

FB_Bac_99063_Mat1_S_026

26

xx

5

Méthodes

Déterminer si des droites sont parallèles

Dans un repère du plan, on donne les droites 𝒟1 et 𝒟2 d’équations cartésiennes respectives ( et non simultanément nuls) et (avec et non simultanément nuls). On considère l’algorithme suivant :


Entrée


:


Saisir les valeurs de et


Traitement


:


prend la valeur

Si





Alors Afficher « Les droites sont parallèles. »

Sinon Afficher « Les droites ne sont pas parallèles. »




Fin Si

1. Justifier que cet algorithme affiche si les droites 𝒟1 et 𝒟2 sont ou ne sont pas parallèles.

2. Qu’affiche cet algorithme en saisissant  ;  ; et ?

3. Même question avec  ;  ; et .

Conseils

Justifiez que la condition «  » permet de contrôler la colinéarité d’un vecteur directeur de 𝒟1 et d’un vecteur directeur de 𝒟2.

Solution

1. Comme 𝒟1 a pour équation cartésienne , le vecteur est un vecteur directeur de 𝒟1.
De même,  est un vecteur directeur de 𝒟2.
Les vecteurs et  sont colinéaires si et seulement si , ou encore ou finalement , ce qui s’écrit Par conséquent :

sialors les vecteurs et sont colinéaires et les droites 𝒟1 et 𝒟2 sont parallèles ;

sinon les vecteurs et ne sont pas colinéaires et les droites 𝒟1 et 𝒟2 ne sont pas parallèles.

2. Les valeurs  ; 6 ; 2 et étant saisies pour et , prend la valeur La condition «  » étant vérifiée, le « Alors » est exécuté et l’algorithme affiche « Les droites sont parallèles. »

3. Les valeurs et étant saisies pour et ,  prend alors la valeur La condition «  » n’étant pas vérifiée, le « Sinon » est exécuté et l’algorithme affiche « Les droites ne sont pas parallèles. »

Vérifier si des points sont alignés

Soient et trois points de coordonnées respectives et Compléter l’algorithme suivant afin qu’il affiche si les points et sont alignés ou non.


Entrée


:


Saisir les valeurs de et


Traitement


:


Si





Alors Afficher «  et … »





Sinon Afficher «  et … »




Fin Si

Conseils

Traduisez l’alignement des points et par la colinéarité des vecteurs et afin de déterminer la condition du « Si ».

Solution

et sont alignés si et seulement si et sont colinéaires, c’est-à-dire si et seulement si ce qui s’écrit à l’aide des coordonnées des points et de la manière suivante :

.

L’algorithme complété est donc le suivant :


Entrée


:


Saisir les valeurs de et


Traitement


:


Si





Alors Afficher «  et sont alignés »

Sinon Afficher «  et ne sont pas alignés »




Fin Si

>>