Algorithmique

Merci !

Fiches
Classe(s) : 2de | Thème(s) : Equations de droites


Méthodes

Établir l’alignement ou non de trois points

On considère l’algorithme suivant :

Entrée

:

Saisir xA, xB, xC, yA, yB et yC (réels).

Traitement

:

Si xA=xB

Alors

Si xA=xC

Alors Afficher « oui »

Sinon Afficher « non »

Fin Si

Sinon a prend la valeur yByAxBxA

b prend la valeur yAa×xA

Si a×xC+b=yC

Alors Afficher « oui »

Sinon Afficher « non »

Fin Si

Fin Si

1. Qu’affiche cet algorithme en saisissant xA=4, xB=1, xC=10, yA=3, yB=6 et yC=5 ?

2. Quel est le rôle de cet algorithme ?

Conseils

Souvenez-vous : « toute droite admet une équation soit de la forme x=c soit de la forme y=ax+b » et « un point appartient à une droite si et seulement si ses coordonnées en vérifient une équation. »

 

Solution

1. Comme xAxB, la condition du Si n’est pas vérifiée et le Sinon s’exécute : a prend la valeur  1 et b prend la valeur 7. Comme a×xC+b=1×10+7=3 est différent de yC=5, la condition du Si n’est pas vérifiée, le Sinon s’exécute et l’algorithme affiche « non ».

2. Si xA=xB, alors (AB) est parallèle à l’axe des ordonnées et admet une équation de la forme x=c (c=xA=xB). Alors, si xA=xC les coordonnées de C vérifient une équation de (AB) et il est affiché « oui » ; sinon il est affiché « non ».

Sinon (xAxB), (AB) n’est pas parallèle à l’axe des ordonnées et admet une équation de la forme y=ax+b avec a=yByAxBxA et b=yAa×xA. Alors, si a×xC+b=yC, les coordonnées de C vérifient une équation de (AB) et il est affiché « oui » ; sinon il est affiché « non ».

Cet algorithme établit ou non l’alignement des points A, B et C.

Étudier le parallélisme de deux droites

Compléter l’algorithme suivant afin qu’il précise l’éventuel parallélisme des droites D1:y=a1x+b1 et D2:y=a2x+b2.

Entrée

:

Saisir les valeurs de a1, b1, a2 et b2 (réels).

Traitement

:

Si a1a2

Alors Afficher « D1 et D2 sont ………. »

Sinon Si b1=b2

Alors Afficher « D1 et D2 sont ………. »

Sinon Afficher « D1 et D2 sont ………. »

Fin Si

Fin Si

Conseils

Notez bien : « étudier le parallélisme de deux droites revient à dire si ces droites sont strictement parallèles, confondues ou sécantes. »

 

Solution

Si a1a2, alors les droites D1 et D2 n’ont pas le même coefficient directeur. Ces droites sont ainsi sécantes. Sinon (a1=a2) ces droites sont parallèles. Si, de plus, b1=b2, alors ces droites ont aussi la même ordonnée à l’origine. Elles admettent, par suite, la même équation réduite et sont confondues. Sinon, elles sont strictement parallèles. La phrase de traitement est donc :

Si a1a2

Alors Afficher « D1 et D2 sont sécantes »

Sinon Si b1=b2

Alors Afficher « D1 et D2 sont confondues »

Sinon Afficher « D1 et D2 sont strictement parallèles »

Fin Si

Fin Si