Algorithmique

Merci !

Fiches
Classe(s) : 2de | Thème(s) : Coordonnées d'un point du plan. Vecteurs


Méthodes

Vérifier si des droites sont parallèles

Soient A, B, C et D quatre points de coordonnées respectives (xA;yA), (xB;yB), (xC;yC) et (xD;yD). Compléter l’algorithme suivant afin qu’il affiche si les droites (AB) et (CD) sont parallèles ou non.

Entrée

:

Saisir les valeurs de xA, yA, xB, yB, xC, yC, xD et yD.

Traitement

:

Si ………. =0

Alors Afficher « Les droites sont parallèles. »

Sinon Afficher « Les droites ne sont pas parallèles. »

Fin Si

Conseils

Traduisez le parallélisme des droites (AB) et (CD) par la colinéarité des vecteurs AB et CD afin de déterminer la condition venant après le « Si ».

 

Solution

(AB) et (CD) sont parallèles si et seulement si AB et CD sont colinéaires, c’est-à-dire si et seulement si xAB×yCDyAB×xCD=0 ce qui s’écrit à l’aide des coordonnées des points A, B, C et D :

(xBxA)×(yDyC)(yByA)×(xDxC)=0.

L’algorithme complété est donc le suivant :

Entrée

:

Saisir les valeurs de xA, yA, xB, yB, xC, yC, xD et yD.

Traitement

:

Si (xBxA)×(yDyC)(yByA)×(xDxC)=0

Alors Afficher « Les droites sont parallèles. »

Sinon Afficher « Les droites ne sont pas parallèles. »

Fin Si

Déterminer les coordonnées d’un point

Soient A, B et C trois points de coordonnées respectives (xA;yA), (xB;yB) et (xC;yC). Compléter l’algorithme suivant afin qu’il affiche, après la saisie des coordonnées des points A, B et C, les coordonnées du point D tel que ABDC soit un parallélogramme.

Entrée

:

Saisir les valeurs de xA, yA, xB, yB, xC et yC.

Traitement

:

xD prend la valeur ………….

yD prend la valeur ………….

Sortie

:

Afficher « L’………. du point D est xD. »

Afficher « L’………. du point D est yD. »

Conseils

Traduisez l’égalité vectorielle AD=AB+AC (règle du parallélogramme) à l’aide de coordonnées. Concluez en exprimant les coordonnées du point D en fonction des coordonnées des autres points.

 

Solution

D’après la règle du parallélogramme, le point D vérifie l’égalité vectorielle AD=AB+AC. Les vecteurs AD et AB+AC étant égaux, ces vecteurs ont les mêmes coordonnées.

Comme AD|xDxAyDyA

et AB+AC |(xBxA)+(xCxA)(yByA)+(yCyA)=|xB+xC2xAyB+yC2yA,

cela amène au système {xDxA=xB+xC2xAyDyA=yB+yC2yA

qui est équivalent à {xD=xB+xCxAyD=yB+yCyA.

L’algorithme complété est donc le suivant :

Entrée

:

Saisir les valeurs de xA, yA, xB, yB, xC et yC.

Traitement

:

xD prend la valeur xB+xCxA

yD prend la valeur yB+yCyA

Sortie

:

Afficher « L’abscisse du point D est xD. »

Afficher « L’ordonnée du point D est yD. »