Algorithmique - Étude de fonctions

Merci !

Fiches
Classe(s) : 1re S | Thème(s) : Étude de fonctions
Corpus Corpus 1
Algorithmique

FB_Bac_99063_Mat1_S_013

13

xx

3

Méthodes

Encadrer une racine

Soit la fonction définie sur par

On admet que l’équation admet une unique solution ? dans et que ? ∈ L’algorithme suivant permet d’en obtenir un encadrement d’amplitude au plus un dixième?:

 

Initialisation

:

prend la valeur

?

?

prend la valeur 2

Traitement

:

Tant que

?

?

?

prend la valeur

?

?

?

prend la valeur

?

?

?

Si

?

?

?

?

Alors prend la valeur

?

?

?

?

Sinon prend la valeur

?

?

?

Fin Si

?

?

Fin Tant que

Sortie

:

Afficher et

 

Quelles sont les valeurs affichées par cet algorithme??

Solution

Après l’initialisation de et , la phase «?Traitement?» débute. Comme la boucle Tant que s’exécute?: prend la valeur puis prend la valeur . Ensuite, la condition du «?Si?» n’étant pas vérifiée le «?Sinon?» s’exécute et prend la valeur Ainsi de suite, jusqu’à ce que .

 

Variables

Signe de

Initialisation

?

?

1

2

1

Étape 1

1,5

1,5

2

0,5

Étape 2

1,75

1,5

1,75

0,25

Étape 3

1,625

1,625

1,75

0,125

Étape 4

1,6875

1,625

1,6875

0,0625

 

L’algorithme affiche 1,625 et 1,6875 (encadrement de la solution).

Calculer une image, si elle existe

Compléter l’algorithme suivant afin qu’il affiche, si elle existe, l’image du réel par fonction définie sur un intervalle par

 

Entrée

:

Saisir la valeur de

Traitement

:

Si

?

?

?

Alors

Afficher «?L’image du réel x n’existe pas.?»

?

?

?

Sinon

Si

?

?

?

?

?

?

Alors

Afficher «?…….?»

?

?

?

?

?

Sinon

Afficher «?…….?»

?

?

?

?

Fin Si

?

?

Fin Si

?

?

 
Conseils

Exprimez sans valeur absolue.

Solution
  • Si alors et

Pour que existe, doit être positif, à savoir

Ainsi, pour tout réel de

Pour n’existe pas.

  • Si alors

et

Pour que existe, doit être positif, à savoir

Ainsi, pour tout réel de

Pour n’existe pas.

  • La fonction est ainsi définie sur

L’algorithme complété est donc le suivant?:

 

Entrée

:

Saisir la valeur de

Traitement

:

Si

?

?

?

Alors

Afficher «?L’image du réel n’existe?pas.?»

?

?

?

Sinon

Si

?

?

?

?

?

Alors

Afficher «?

?

?

?

?

?

Sinon

Afficher «?

?

?

?

?

Fin Si

?

?

Fin Si

?

?

 

>>