Algorithmique : Probabilités - Lois discrètes

Merci !

Fiches
Classe(s) : Tle ES - Tle L | Thème(s) : Notion de loi à densité
Corpus Corpus 1
Algorithmique

FB_Bac_98616_MatT_LES_036

36

xx

5

Méthodes

Comprendre un algorithme

Dans l&rsquo expérience aléatoire simulée par l&rsquo algorithme suivant, on appelle X la variable aléatoire prenant la valeur C affichée.

Quelle loi suit la variable X?? Préciser ses paramètres.

A et C sont des entiers naturels.

Début

C prend la valeur 0.

Répéter 9 fois

A prend une valeur aléatoire entière entre 1 et 7.

SiA &gt ?5 alors C prend la valeur de C +?1

Fin Si

Fin répéter

Afficher C.

Fin

Conseils

Pour comprendre un algorithme, on le fait fonctionner en notant les valeurs prises par les variables aux différentes étapes.

Solution

L&rsquo expérience aléatoire consiste à tirer au hasard un nombre entier entre 1 et 7?:

  • soit le nombre est entre 1 et 5, avec une probabilité de ?
  • soit il vaut 6 ou 7, avec une probabilité de .

Puisque C est le nombre de fois où on a obtenu 6 ou 7, la variable aléatoire X suit une loi binomiale de paramètres 9 et .

Simuler une expérience aléatoire

Une personne fortement alcoolisée quitte un restaurant R et souhaite atteindre l&rsquo arrêt de bus B. Elle se dirige vers le point B en diagonale, vers la gauche ou vers la droite, avec une même probabilité de 0,5. On suppose qu&rsquo elle fait 20 pas de longueurs identiques. Voir l&rsquo exemple de trajet ci-après.


&nbsp

Voici un algorithme simulant une telle &laquo ?marche aléatoire?&raquo ?:

D prend la valeur 0.

Pour I de 1 à 20?:

P prend aléatoirement la valeur &ndash 1 ou 1?

SiP =?1 alorsD prend la valeur D +?1?

Fin Si.

Fin Pour.

Afficher D.

a.?Que représente la variable D?? Quelles sont les valeurs possibles de D?? Que se passe-t-il lorsque D =?10??

b.?Modifier cet algorithme pour qu&rsquo il soit exécuté 10?000 fois et qu&rsquo il calcule le nombre de fois où la personne a rejoint l&rsquo arrêt de bus.

Conseils

Si P prend la valeur &ndash 1, cela peut représenter un pas à gauche.

Solution

a.D compte le nombre de pas à droite, les valeurs possibles sont les entiers de 0 à 20. Si D =?10, la personne a atteint l&rsquo arrêt de bus.

b.?La variable B compte le nombre de fois où l&rsquo arrêt de bus est atteint. L&rsquo affichage final donne le nombre moyen de fois où l&rsquo arrêt de bus a été atteint.

Début

B prend la valeur 0.

PourJ de 1 à 10?000?:

D prend la valeur 0.

Pour I de 1 à 20?:

P prend aléatoirement la valeur &ndash 1 ou 1?

SiP =?1 alorsD prend la valeur D +?1?

Fin Si.

Fin Pour.

SiD =?10 alorsB prend la valeur B +?1.

Fin Si.

Fin Pour.

Afficher B/10?000.

Fin

>>