Algorithmique : Statistique

Merci !

Fiches
Classe(s) : Tle ES - Tle L | Thème(s) : Intervalle de fluctuation - Estimation
Corpus Corpus 1
Algorithmique

FB_Bac_98616_MatT_LES_045

45

xx

6

Méthode

Déterminer un taux moyen avec un algorithme

Écrire un algorithme permettant de saisir plusieurs taux d’évolutions afin de retourner le taux moyen d’évolution.

Conseils

Une possibilité est de demander le nombre d’évolutions à saisir et d’utiliser une boucle Pour.

Solution

Les commentaires de chaque ligne commencent par le symbole #.


 

Estimer une intégrale via la méthode de Monte-Carlo

On considère une fonction définie, continue et positive sur .

Début

C =?0.

PourI de 1 à 100?000?:

X est un nombre réel aléatoire pris dans [0?; 1]?;

Y est un nombre réel aléatoire pris dans [0?; 1]?;

SiY <?=?f (X) alorsC prend la valeur C +?1?;

Fin Si.

Fin Pour.

Afficher C/ 100?000.

Fin

a.?Décrire la variable C et expliquer ce qu’affiche cet algorithme.

b.?Si , l’algorithme donne en sortie 0,34296. Était-ce prévisible??

c.?Modifier cet algorithme pour qu’il permette de saisir un nombre de points N puis retrouve un intervalle de confiance au niveau de confiance 95?% de la fréquence de points sous la courbe.

Conseils

a.?100?000 fois, un couple de valeurs est pris au hasard entre 0 et 1. On peut imaginer qu’il s’agit de points, de coordonnées (X?; Y  ), placés dans un repère orthonormal. On pourra se demander quelle partie du plan est décrite par la condition «?Y <?=?f (X  )?».

b.?Cette fonction est la densité de la loi normale centrée réduite.

Solution

a.C compte le nombre de points situés au-dessous de la courbe de . L’algorithme affiche la proportion de ces points par rapport aux 100?000 points pris au hasard dans le carré unité.

Ainsi, cette valeur est une estimation de .

b.?Cette fonction est la densité de la loi normale centrée réduite. Lorsqu’une variable aléatoire X suit cette loi, on connaît la valeur remarquable , ce qui donne par symétrie?: . Par conséquent, .

Début

C =?0.

Saisir N.

PourI de 1 à N?:

X est un nombre réel aléatoire pris dans [0?; 1]?;

Y est un nombre réel aléatoire pris dans [0?; 1]?;

SiY <?=?f (X) alorsC prend la valeur C +?1?;

Fin Si.

Fin Pour.

R prend la valeur.

Afficher C/NR et C/N +?R.

Fin

>>