Algorithmique : Statistique

Merci !

Fiches
Classe(s) : Tle ES - Tle L | Thème(s) : Intervalle de fluctuation - Estimation
Corpus Corpus 1
Algorithmique

FB_Bac_98616_MatT_LES_045

45

xx

6

Méthode

Déterminer un taux moyen avec un algorithme

Écrire un algorithme permettant de saisir plusieurs taux d&rsquo évolutions afin de retourner le taux moyen d&rsquo évolution.

Conseils

Une possibilité est de demander le nombre d&rsquo évolutions à saisir et d&rsquo utiliser une boucle Pour.

Solution

Les commentaires de chaque ligne commencent par le symbole #.


&nbsp

Estimer une intégrale via la méthode de Monte-Carlo

On considère une fonction définie, continue et positive sur .

Début

C =?0.

PourI de 1 à 100?000?:

X est un nombre réel aléatoire pris dans [0? 1]?

Y est un nombre réel aléatoire pris dans [0? 1]?

SiY &lt ?=?f (X) alorsC prend la valeur C +?1?

Fin Si.

Fin Pour.

Afficher C/&thinsp 100?000.

Fin

a.?Décrire la variable C et expliquer ce qu&rsquo affiche cet algorithme.

b.?Si , l&rsquo algorithme donne en sortie 0,34296. Était-ce prévisible??

c.?Modifier cet algorithme pour qu&rsquo il permette de saisir un nombre de points N puis retrouve un intervalle de confiance au niveau de confiance 95?% de la fréquence de points sous la courbe.

Conseils

a.?100?000 fois, un couple de valeurs est pris au hasard entre 0 et 1. On peut imaginer qu&rsquo il s&rsquo agit de points, de coordonnées (X? Y&thinsp &thinsp ), placés dans un repère orthonormal. On pourra se demander quelle partie du plan est décrite par la condition &laquo ?Y &lt ?=?f (X&thinsp &thinsp )?&raquo .

b.?Cette fonction est la densité de la loi normale centrée réduite.

Solution

a.C compte le nombre de points situés au-dessous de la courbe de . L&rsquo algorithme affiche la proportion de ces points par rapport aux 100?000 points pris au hasard dans le carré unité.

Ainsi, cette valeur est une estimation de .

b.?Cette fonction est la densité de la loi normale centrée réduite. Lorsqu&rsquo une variable aléatoire X suit cette loi, on connaît la valeur remarquable , ce qui donne par symétrie?: . Par conséquent, .

Début

C =?0.

Saisir N.

PourI de 1 à N?:

X est un nombre réel aléatoire pris dans [0? 1]?

Y est un nombre réel aléatoire pris dans [0? 1]?

SiY &lt ?=?f (X) alorsC prend la valeur C +?1?

Fin Si.

Fin Pour.

R prend la valeur.

Afficher C/N &ndash R et C/N +?R.

Fin

>>