Exercice corrigé Ancien programme

algorithme

1. Écrire un algorithme donnant les solutions réelles de l'équation (E) où a, b et c sont des réels, avec

Pour cela, il suffit de reprendre l'algorithme de l'exercice 15 du chapitre « fonction exponentielle », et d'y intégrer l'expression des solutions de (E).

Les solutions de (E) sont :

la solution éventuelle de l'équation est l'unique racine du trinôme

les solutions éventuelles des équations sont les racines du trinôme

2. Tester l'algorithme sur les équations suivantes :

a.

b.

c.

d.

1.

VARIABLES

a EST_DU_TYPE NOMBRE

b EST_DU_TYPE NOMBRE

c EST_DU_TYPE NOMBRE

x0 EST_DU_TYPE NOMBRE

x1 EST_DU_TYPE NOMBRE

x2 EST_DU_TYPE NOMBRE

DELTA EST_DU_TYPE NOMBRE

DEBUT_ALGORITHME

LIRE a

LIRE b

LIRE c

SI (a!=0) ALORS

DEBUT_SI

DELTA PREND_LA_VALEUR b*b-4*a*c

SI (DELTA= =0) ALORS

DEBUT_SI

x0 PREND_LA_VALEUR –b/(2*a)

SI (x0>0) ALORS

DEBUT_SI

AFFICHER “|'équation a exp(2x)+b exp(x)+c=0 admet pour solution x = ln”

AFFICHER x0

FIN_SI

SINON

DEBUT_SINON

AFFICHER “|'équation a exp(2x)+b exp(x)+c=0 n'admet aucune solution”

FIN_SINON

FIN_Si

SINON

DEBUT_SINON

SI(DELTA > 0)ALORS

DEBUT_SI

x1 PREND_LA_VALEUR (-b-sqrt(DELTA))/(2*a)

x2 PREND_LA_VALEUR (-b+sqrt(DELTA))/(2*a)

SI(x1>0ET x2 > 0)ALORS

DEBUT_SI

AFFICHER “|'équation a exp(2x)+b exp(x)+c=0 admet pour solutions x = ln”

AFFICHER x1

AFFICHER “et x = ln”

AFFICHER x2

FIN_SI

SINON

DEBUT_SINON

SI (X1

DEBUT_SI

AFFICHER “|”équation a exp(2x)+b exp(x)+c=0 n'admet aucune solution”

FIN_SI

SINON

DEBUT_SINON

AFFICHER “|'équation a exp(2x)+b exp(x)+c=0 admet pour solution x = ln”

SI (x1>0) ALORS

DEBUT_SI

AFFICHER x1

FIN_SI

SINON

DEBUT_SINON

AFFICHER x2

FIN_SINON

FIN_SINON

FIN_SINON

FIN_SI

SINON

DEBUT_SINON

AFFICHER “|'équation a exp(2x)+b exp(x)+c=0 n'admet aucune solution”

FIN_SINON

FIN_SINON

FIN_SI

FIN_ALGORITHME

2. a.

***Algorithme lancé***

1 ‘équation a exp(2x)+b exp(x)+c=0 admet pour solution x = ln 1

***Algorithme terminé***

b.

***Algorithme lancé***

1 ‘équation a exp(2x)+b exp(x)+c=0 n‘admet aucune solution

***Algorithme terminé***

c.

***Algorithme lancé***

1 ‘équation a exp(2x)+b exp(x)+c=0 admet pour solution x = ln 1.5 et x = ln 4

***Algorithme terminé***

d.

***Algorithme lancé***

1 ‘équation a exp(2x)+b exp(x)+c=0 n‘admet aucune solution

***Algorithme terminé***

Accéder à tous les contenus
dès 6,79€/mois

  • Les dernières annales corrigées et expliquées
  • Des fiches de cours et cours vidéo/audio
  • Des conseils et méthodes pour réussir ses examens
  • Pas de publicités
S'abonner