Exercice corrigé Ancien programme

algorithme : racines cubiques

Notons f la fonction cube définie sur .

1. Justifier que f est continue et strictement monotone sur

2. Soit k un réel. Montrer que l'équation admet une unique solution sur .

3. Donner la solution de chacune des équations :

4. Écrire un algorithme associant à un réel k positif :

  • la valeur de x0 si x0 est un entier 
  • un encadrement à l'unité de x0 sinon.

Utiliser la boucle « Tant que ».

5. Écrire un algorithme associant à un réel k positif un encadrement au dixième de x0.

On ne traite pas ici le cas k négatif, mais, comme la fonction cube est impaire,

si l'algorithme appliqué à donne alors 

1. f est une fonction polynôme, donc elle est continue et dérivable sur
Pour tout x réel,

f est positive sur et s'annule en 0, donc f est strictement croissante sur .

2. Soit k un réel.

  • f est continue et strictement croissante sur
  • k est compris entre et

Donc, d'après le corollaire du théorème des valeurs intermédiaires, l'équation admet une unique solution x0 sur .

3.

4.

VARIABLES

k EST_DU_TYPE NOMBRE

a EST_DU_TYPE NOMBRE

b EST_DU_TYPE NOMBRE

DEBUT_ALGORITHME

LIRE K

b PREND_LA_VALEUR 0

SI (k > = 0) ALORS

DEBUT_SI

TANT_QUE (pow(b,3)

DEBUT_TANT_QUE

b PREND_LA_VALEUR b+1

FIN_TANT_QUE

a PREND_LA_VALEUR b-1

SI (pow(b,3)==k) ALORS

DEBUT_SI

AFFICHER “X0 = ”

AFFICHER b

FIN_SI

SINON

DEBUT_SINON

AFFICHER “x0 est compris entre”

AFFICHER a

AFFICHER “et ”

AFFICHER b

FIN_SINON

FIN_SI

FIN_ALGORITHME

5.

VARIABLES

k EST_DU_TYPE NOMBRE

b EST_DU_TYPE NOMBRE

a EST_DU_TYPE NOMBRE

DEBUT_ALGORITHME

LIRE K

b PREND_LA_VALEUR 0

SI (k>=0) ALORS

DEBUT_SI

TANT_QUE (pow(b,3)

DEBUT_TANT_QUE

b PREND_LA_VALEUR b+1

FIN_TANT_QUE

a PREND_LA_VALEUR b-1

SI (pow(b,3)==k) ALORS

DEBUT_SI

AFFICHER “x0 =”

AFFICHER b

FIN_SI

SINON

DEBUT_SINON

b PREND_LA_VALEUR a

TANT_QUE (pow(b,3)

DEBUT_TANT_QUE

b PREND_LA_VALEUR b+0.1

FIN_TANT_QUE

a PREND_LA_VALEUR b-0.1

AFFICHER “x0 est compris entre”

AFFICHER a

AFFICHER “et”

AFFICHER b

FIN_SINON

FIN_SI

FIN_ALGORITHME

Le logiciel Algobox n'est pas capable de tester correctement une égalité du style « si alors… » s'il s'agit de décimaux. On doit donc se contenter ici d'inégalités larges pour l'encadrement de x0.

Accéder à tous les contenus
dès 6,79€/mois

  • Les dernières annales corrigées et expliquées
  • Des fiches de cours et cours vidéo/audio
  • Des conseils et méthodes pour réussir ses examens
  • Pas de publicités
S'abonner